Loading


Advertisement:

Author Topic: [SOLVED] Getting Error Message on Photo Uploads (XHR returned response code 500)  (Read 8699 times)

ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Hello,
    Recently I was trying to upload the photos for an ad I intend to publish. But everytime I upload the photo I get the message Retry Upload failed and error message " XHR returned response code 500 ". I tried to make a fresh new ad but again meet with similar situation is there any way to fix in permanently.

I am using GD library for images.
« Last Edit: March 31, 2016, 09:21:24 am by ColdWabmaster »

Aficionado

  • Hero Member
  • *****
  • Posts: 4023
  • Good things come to those who wait
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #1 on: September 29, 2014, 08:13:39 pm »
XHR ?

It's usually caused by bad permissions in the php sessions storage.

ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #2 on: September 29, 2014, 08:50:36 pm »
What I have to do I am not able to upload images of higher resolution and greater than 100 KB. Only image of 20 or 30 KB are uploading. Anyway to fix it ... what caused it ?

I am also seeing usual foldername in oc-content/uploads..


Aficionado

  • Hero Member
  • *****
  • Posts: 4023
  • Good things come to those who wait
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #3 on: September 29, 2014, 09:26:48 pm »
If it is a size limitation, then contact your hosting provider.


ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #4 on: September 29, 2014, 09:38:09 pm »
What about the folder with name 0 is it some sort of hacking ...  :-\
Also I found a file in the folder HTML as shown in above image as fully chinese script. Is it some bug or hackcode ..?

Aficionado

  • Hero Member
  • *****
  • Posts: 4023
  • Good things come to those who wait
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #5 on: September 29, 2014, 09:50:38 pm »
What about the folder with name 0 is it some sort of hacking ...  :-\
Also I found a file in the folder HTML as shown in above image as fully chinese script. Is it some bug or hackcode ..?

No it is normal folder naming. Don't worry about that.

About the script, i have no idea.

ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #6 on: September 29, 2014, 10:28:15 pm »
I have submitted a support ticket to server provider too. My wordpress is also showing upload errors . :P

ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #7 on: September 30, 2014, 07:50:21 am »
My server provider informed that it may due to the script and there is no limitation from server end ...! Now what to do .. :-\

albertorma

  • Newbie
  • *
  • Posts: 13
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #8 on: October 16, 2015, 04:21:19 am »
Same problem to me... Extrangly yesterday my website was working properly, any solution?

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1525
  • osclass.work
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #9 on: October 16, 2015, 06:50:14 am »
re-download 3.5.8 zip and replace all files, there was a typo in initial version.

http://forums.osclass.org/3-5-x/error-xhr-returned-response-code-500/msg131227/#msg131227

albertorma

  • Newbie
  • *
  • Posts: 13
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #10 on: October 20, 2015, 07:56:57 pm »
Well It fixed by itself, probably due to the 3.5.9. auto-update. thanks anyway!

derickn6

  • Newbie
  • *
  • Posts: 1
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #11 on: January 25, 2016, 12:39:11 pm »
I got the same issue. I installed New Osclass 3.6 and I got this error. "XHR returned response code 500" I hope somebody would help me.

ColdWabmaster

  • Full Member
  • ***
  • Posts: 146
Re: Getting Error Message on Photo Uploads (XHR returned response code 500)
« Reply #12 on: March 09, 2016, 02:10:47 pm »
Again I am also getting the same error. I installed New Osclass 3.6.1 and I got this error. "XHR returned response code 500" while image is not uploading for those who trys to publish the ads in the classified.


ColdWabmaster

  • Full Member
  • ***
  • Posts: 146