Loading


Advertisement:

Author Topic: Add all working Plug-ins to all scripts.  (Read 2680 times)

Sandlent

  • Newbie
  • *
  • Posts: 1
Add all working Plug-ins to all scripts.
« on: December 14, 2012, 04:18:30 am »
I've been reading all the forums and seeing how much trouble that folks are  having getting most of the plug-ins working.  By adding all working plug-ins to all the scripts and have them working out of the box would take care of all the frustration. If they don't need a plug-in it can be uninstalled by the user after they have road tested the script.
I know a couple of the plug-ins I've installed didn't work right and I had to twink them or my pages to get them working right.


_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4389
Re: Add all working Plug-ins to all scripts.
« Reply #1 on: December 17, 2012, 11:26:57 am »
Hi Sandlent,

I really don't understand your suggestion, but I will try to answer it.

First of all, If we add ALL the plugins to the download, the file will be massive, plus you probably don't want to have 40 plugins if you're only going to use 1 or 2. We let the users decide which ones they want.

In addition, Osclass team only develop some of the plugins out there, not every one, that's the reason of a plugin to exists, so anyone could make the changes they want to Osclass. We do not have the time or resources to check every plugin if it works correctly.

Most of the problem could be due to incompatibility problems which the Osclass version and/or the server configuration. Again, we took our time to make Osclass as compatible as possible with every known configuration of server out there. We have several configurations in our own servers and test Osclass there, some developers may not have as many as ours, they could develop a perfectly plugin working on PHP 5.3, but that it will not work on PHP5.2, also, they probably don't test it against old versions of Osclass.


We're trying to fix that with out market. In http://market.osclass.org/ you will find the versions the plugin is compatible with. Also in the admin panel, it will tell you that the plugin is not compatible with your version and warn you about it. We're studying ways of people to collaborate with us in the market, so they could upload their plugins to it, but also we want to maintain the quality, so we'll need to find a way to test if they work or not, and that's a lot of money, time and resources we currently don't have.


Thanks