Advertisement:

Author Topic: Empty categories on homepage not working  (Read 3125 times)

Adyyda

  • Sr. Member
  • ****
  • Posts: 439
Empty categories on homepage not working
« on: November 14, 2014, 01:02:59 pm »
I have made a clean install of 3.5 and i see that this version was "improved" because now, on home page i see all categories, i can click on any with an ad but on those with no ads (0), no action is performed, no message is shown to the user. This improvement is a really bad idea.
Some requested that empty categories to be hidden. And by that, we should have an admin option to show all categories even if they are empty, or hide the ones without ads.
So we have now a broken function compared to previous version and no improvement as requested. Nice job. What other improvements were made?

I can specify another one right now...If we have in admin area just 1 country, dropdown field Country should be active and hidden because there is nothing else to chose from.

As a improvement i see that we have now ajax fill in for Location fields (except Country as stated before) which works ok and solves the issue of lag when selecting Region and than see wrong City because of slow interogation of database

garciademarina

  • Administrator
  • Hero Member
  • *****
  • Posts: 973
Re: Empty categories on homepage not working
« Reply #1 on: November 14, 2014, 06:53:42 pm »
Hi,

Only Parent categories are clickable, sub categories don't have links. I just create an issue to fix it. https://github.com/osclass/Osclass/issues/1764

( Also take in mind that search pages if there aren't results back, 404 code is returned )

Inside the zip file you will find the CHANGELOG.txt file if you want to see a summary of improvements and fixes.

Note that you can also add github issues to report bug/issues
https://github.com/osclass/Osclass/issues

Regards


Adyyda

  • Sr. Member
  • ****
  • Posts: 439
Re: Empty categories on homepage not working
« Reply #2 on: November 14, 2014, 08:23:54 pm »
Hi,

Only Parent categories are clickable, sub categories don't have links. I just create an issue to fix it. https://github.com/osclass/Osclass/issues/1764

( Also take in mind that search pages if there aren't results back, 404 code is returned )

Inside the zip file you will find the CHANGELOG.txt file if you want to see a summary of improvements and fixes.

Note that you can also add github issues to report bug/issues
https://github.com/osclass/Osclass/issues

Regards


if a category or subcategory has no ads, the links will be like http://demo.osclass.org/general/#
if a category or subcategory has at least 1 ads, we have proper link like http://demo.osclass.org/general/index.php?page=search&sCategory=31

you can add 1 listing to any category/subcategory without any ad and from non working will start working.

garciademarina

  • Administrator
  • Hero Member
  • *****
  • Posts: 973
Re: Empty categories on homepage not working
« Reply #3 on: November 17, 2014, 02:52:46 pm »
Hi,


Thats right, categories/subcategories without listings will have href="#" as link.

It will be fixed on the next release.


pixel375

  • Newbie
  • *
  • Posts: 6
Re: Empty categories on homepage not working
« Reply #4 on: April 07, 2017, 02:16:04 am »
Hi,


Thats right, categories/subcategories without listings will have href="#" as link.

It will be fixed on the next release.

Sorry for grave digging. But any update on this "Issue"?

conradslist

  • Newbie
  • *
  • Posts: 1
Re: Empty categories on homepage not working
« Reply #5 on: May 11, 2018, 12:19:55 am »
Has anyone got around this issue? Noob here and loving the script, but need to fix this issue.

Any help will be highly appreacited

Resta

  • Sr. Member
  • ****
  • Posts: 348
Re: Empty categories on homepage not working
« Reply #6 on: May 12, 2018, 05:15:56 am »
Sadly, after so many revisions this basic but important issue (also that shows on the main page of every installation) has not been addressed along with wrong item counts showing on the main page. If you know how to edit the page, you are better off removing the automated category links on the main page ad those links manually without showing the item counts because the item counts will show wrong.

pixelpadre

  • Jr. Member
  • **
  • Posts: 74
Re: Empty categories on homepage not working
« Reply #7 on: December 29, 2018, 02:52:17 am »
I have empty categories on main page with no listing counts.  Why is this happening.

marius-ciclistu

  • issues
  • Hero Member
  • *
  • Posts: 1700
  • "BE GRATEFUL TO THOSE THAT SUPPORTED YOU"
Re: Empty categories on homepage not working
« Reply #8 on: December 29, 2018, 09:36:55 am »
 I solved the item counts in one of my posts.
The code does not put a link into empty categories on main page. That behaviour can be changed also in the theme main.pho file if I remember right.

pixel375

  • Newbie
  • *
  • Posts: 6
Re: Empty categories on homepage not working
« Reply #9 on: March 18, 2019, 11:54:01 pm »
Still having this issue...

marius-ciclistu

  • issues
  • Hero Member
  • *
  • Posts: 1700
  • "BE GRATEFUL TO THOSE THAT SUPPORTED YOU"
Re: Empty categories on homepage not working
« Reply #10 on: March 19, 2019, 12:22:16 am »
Because it is a feature not a bug.

pixel375

  • Newbie
  • *
  • Posts: 6
Re: Empty categories on homepage not working
« Reply #11 on: March 21, 2019, 11:31:09 pm »
How is having a category that just refreshes the page on click a feature?
It should be either
1. Redirecting to a page that says this category is empty
2. Hide the category entirely

Else it just confuses the users.

I'm too stupid to solve this crap without help, so I guess I will have to buy a different Classifieds script, cause this is just plain stupid.