Loading


Advertisement:

Author Topic: Upgrade problems? post here  (Read 15558 times)

keerthi

  • Hero Member
  • *****
  • Posts: 505
totally ruined the upgrade.
« Reply #15 on: August 05, 2014, 08:49:17 am »
I tried auto-upgrading to osclass 3.4 without disabling permalinks, and without putting the site into maintanece mode.

After auto-upgrade it gave error in logdatabase.php in oc-includes.  I even tried replacing the files which gives up warnings during extraction. after extraction it gave internal server error.

I do have a backup of oc-content and mysql.

what should I do now?

My site is sellrbuyr.in.
« Last Edit: August 05, 2014, 09:01:50 am by keerthi »

kweku

  • Sr. Member
  • ****
  • Posts: 291
  • my Internet + MAC = direction. speak less.
We failed trying to upgrade your site to Osclass 3.4.0 ???? new message
« Reply #16 on: August 05, 2014, 09:45:18 am »
I found out that my website turn into maintenance mode automatically. and this was the message i got;



We failed trying to upgrade your site to Osclass 3.4.0. Heres is the error message: Unzip failed

If you experience any issues or need support, we will be happy to help you at the Osclass support forums

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4690
Re: Stuck in Maintenance Mode
« Reply #17 on: August 05, 2014, 10:16:34 am »
Admin panel > tools > maintenance mode and disable it, or go to the root folder of your website and remove ".maintenance" file (has a dot "." before the name and could be invisible to some FTP clients)

If your installation is at maintenance mode is because the upgrade failed at some point and you need to check that everything is ok now.
Please try to upgrade again, if the error continue, I suggest you to upgrade manually : http://doc.osclass.org/Updating_Osclass

From which version were you upgrading from ?

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4690
Re: totally ruined the upgrade.
« Reply #18 on: August 05, 2014, 10:34:32 am »
Please try manual updating http://doc.osclass.org/Updating_Osclass

ozclix

  • Jr. Member
  • **
  • Posts: 69
Upgrade issue resolved by restoring earlier version.
« Reply #19 on: August 05, 2014, 10:37:07 am »
Hi all, I have been a little quiet lately.

I did type the below post in another thread but saw that any issues should be reported here so I have repeated it below:

I went to log into my admin panel and was surprised that I got an error message come up...something along the lines of Sparse Error, unexpected ( : ) and a synax error on line 140 on one of the log files ( sorry I should have copy and pasted it somewhere but panicked when I realised my main site also brought up the same error).

I was however able to access Ozclass via Instaltron who supplied ozclass via my provider and saw that it had automatically updated to version 3.4.  Figuring that the error must have come from the upgrade I threw back to a back up (because we all do that don't we ;) ) from pre 3.4 update and it now works again. 

I know I am not much help with the error for the transition to 3.4 as I didn't copy it but if it does help I am using the original bender theme with minimal add-ons.  My update settings are set to automatically update minor bugs and fixes but didn't expect a major update. 

Anyway, thanks everyone for their hard work and maybe I will be able to update at a later time or something without any issues popping up.

Jay
« Last Edit: August 05, 2014, 10:55:09 am by ozclix »

garciademarina

  • Administrator
  • Hero Member
  • *****
  • Posts: 942
Re: We failed trying to upgrade your site to Osclass 3.4.0 ???? new message
« Reply #20 on: August 05, 2014, 01:19:58 pm »
Hi there,

What version are you trying to upgrade?

Regards

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5296
  • Hardliner
Re: Stuck in Maintenance Mode
« Reply #21 on: August 05, 2014, 03:10:24 pm »
I can verify this, my installations also went into maintenance mode for no reason.

It seems to be a problem with automatic updates.

Quote
Dear dev admin,

We failed trying to upgrade your site to Osclass 3.4.0. Heres is the error message: Unzip failed

If you experience any issues or need support, we will be happy to help you at the Osclass support forums

http://forums.osclass.org/

The Osclass team

I was trying to go from 3.3.2 to 3.4.

In my setup everything is in order, a full 3.3.2 working website, all permissions are intact. So this is a problem of Osclass. And i did update several Osclass versions before, so this is new.
« Last Edit: August 05, 2014, 03:17:32 pm by Aficionado »

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5296
  • Hardliner
Re: Stuck in Maintenance Mode
« Reply #22 on: August 05, 2014, 03:23:39 pm »
It seems that 3.4 was downloaded (in downloads) but nothing else happened.

So i deleted the file, disabled Maintenance Mode, disabled Automatic Updates of any kind, and i selected Upgrade. The upgrade worked right and after a while it finished and everything seems ok.

I still see "3.4.0 is available" on the top of the dashboard for some reason.


dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1829
  • osclass.work
Re: Stuck in Maintenance Mode
« Reply #23 on: August 05, 2014, 03:24:46 pm »
I think Conejo made a plugin for updating to 340 from 332, can't remember the link but its on front page somewhere.

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5296
  • Hardliner
Re: Stuck in Maintenance Mode
« Reply #24 on: August 05, 2014, 03:27:16 pm »
Also my debug.log seems busy, are all those normal ?


dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1829
  • osclass.work
Re: Stuck in Maintenance Mode
« Reply #25 on: August 05, 2014, 03:36:41 pm »
database upgrade, unless you see some errors, nothing to be alarmed of.

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5296
  • Hardliner
Re: Stuck in Maintenance Mode
« Reply #26 on: August 05, 2014, 03:39:18 pm »
database upgrade, unless you see some errors, nothing to be alarmed of.

You mean for example:

[05-Aug-2014 13:21:31 Europe/Madrid]  --- dt_expiration datetime NOT NULL DEFAULT '9999-12-31 23:59:59'

is normal ?


dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1829
  • osclass.work
Re: Stuck in Maintenance Mode
« Reply #27 on: August 05, 2014, 03:41:33 pm »
Yes, SQL statement from struct.sql file.

RBlack963

  • Jr. Member
  • **
  • Posts: 77
Help! Site is down!
« Reply #28 on: August 05, 2014, 03:49:37 pm »
I have OSCLass set to automatically update to newer versions.  I woke up today to find that my site is down for maintenance.  I have an email saying:

We failed trying to upgrade your site to Osclass 3.4.0. Heres is the error message: Unzip failed

How do I fix this please!


Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5296
  • Hardliner
Re: Stuck in Maintenance Mode
« Reply #29 on: August 05, 2014, 03:57:03 pm »
Yes, SQL statement from struct.sql file.

Thanks.

Any ideas why i still see the Update available 3.4 on my top of my admin dashboard ? It should be like that ?