Advertisement:

Author Topic: where can i find older versions of osclass?  (Read 92 times)

devilal

  • Newbie
  • *
  • Posts: 2
where can i find older versions of osclass?
« on: February 08, 2019, 01:13:16 pm »
where can i find older versions of osclass? I need a version that is compatible with php 5.3. thanks

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2011
  • osclass.work
Re: where can i find older versions of osclass?
« Reply #1 on: February 08, 2019, 04:13:24 pm »
That is a very old PHP version, and the 'newest' Osclass that could be officially installed on it is osclass.3.6.1.zip.
You have releases here: https://github.com/osclass/Osclass/releases

You can try installing latest 3.8.0 if you edit manually this line (no guarantees though, but it should work in general, because all compatibility libs are still present):

https://github.com/osclass/Osclass/blob/master/oc-includes/osclass/install-functions.php#L101

Code: [Select]
'fn' => version_compare(PHP_VERSION, '5.3.0', '>='),

devilal

  • Newbie
  • *
  • Posts: 2
Re: where can i find older versions of osclass?
« Reply #2 on: February 10, 2019, 12:37:39 pm »
thanks it worked  :)