Osclass forums

Language Specific => Español => Ayuda => Topic started by: jabixo on May 10, 2011, 10:26:12 pm

Title: Error en la instalación de OSclass
Post by: jabixo on May 10, 2011, 10:26:12 pm
Hola, mi nombre es Javi. He instalado el script pero en el step 5 me surge un problema, porque debería crearme una contraseña para poder entrar al admin y no lo hace, simplemente se queda en blanco y vuelvo a refrescar la página y me aparece: "You appear to have already installed OSClass. To reinstall please clear your old database tables first."

¿Qué puedo hacer? ayuda por favor :)
Un saludo
Javi.
Title: Re: Error en la instalación de OSclass
Post by: Juan Ramón on May 11, 2011, 01:41:19 pm
- ¿Cuando entras a la página principal te aparece algo?
- ¿Te llego un e-mail al finalizar la instalación?
- ¿Si intentas recuperar la contraseña a través del Forgot password? del oc-admin te llega un correo?
- En caso de que sepas mirar la base de datos: ¿Te aparece algún usuario en la tabla t_admin?

Espero que con estas preguntas podamos resolver el problema :)
Title: Re: Error en la instalación de OSclass
Post by: jabixo on May 14, 2011, 03:14:13 pm
-Si , cuando entro en la pagina principal me aparece todo bien , pero no puedo entrar en la administración porque en el ultimo paso de la instalación no me aparecía lo que en teoría debería aparecerme que es el nombre de usuario y contraseña.
-No, no me llegó ningún e-mail
-Cuando intento recuperar la contraseña , me dice que me han enviado un e-mail pero no me llega.
-Y no, no me aparece ningún usuario..

(Yo pienso que puede ser por el hosting, que como es gratuito, alomejor tiene limitaciones como las de enviar e-mails, no lo sé porque no me he leido las prestaciones que tiene... el hosting que uso es byethost)

Gracias por la ayuda :) Un saludo
Title: Re: Error en la instalación de OSclass
Post by: Juan Ramón on May 16, 2011, 05:26:11 pm
Que extraño... Me puedes decir si te aparece algún usuario en la tabla t_admin en la base de datos? Deberás acceder al phpMyAdmin para verlo.
Title: Re: Error en la instalación de OSclass
Post by: jabixo on May 16, 2011, 10:18:06 pm
si que me aparece el usuario de admin con mi correo electronico, pero no me apareció la contraseña y el username al final de la instalación.. :S
Title: Re: Error en la instalación de OSclass
Post by: Juan Ramón on May 17, 2011, 08:32:57 pm
Que extraño... Y si pruebas a actualizar la contraseña a través del phpMyAdmin? En {password} pon lo que quieras.

UPDATE oc_t_admin SET s_password = sha1('{password}') WHERE pk_i_id = '1';
Title: Re: Error en la instalación de OSclass
Post by: jabixo on May 17, 2011, 09:08:04 pm
Justo eso he probado cuando me dijiste que viera si habia algun usuario en la base de datos. He visto que se puede editar y la he cambiado pero tampoco me deja entrar.. me pone que el password no es el correcto..
Title: Re: Error en la instalación de OSclass
Post by: Juan Ramón on May 17, 2011, 09:17:33 pm
Es muy extraño... Cuando has modificado el password has hecho lo de sha1?
Title: Re: Error en la instalación de OSclass
Post by: jabixo on May 18, 2011, 03:50:36 pm
Vale ya está claro, era eso que tu dices del sha1 que no lo había hecho, muchas gracias por resolverme la duda :D