Loading


Advertisement:

Author Topic: reCaptcha not working  (Read 2577 times)

calidude38

  • Newbie
  • *
  • Posts: 10
reCaptcha not working
« on: June 30, 2014, 09:02:17 pm »
I have OSclass version 3.3.2 and the latest Bender theme and I enabled recaptch. It shows up correctly but when I try to register it keeps telling me captcha not entered correctly... I am sure it is.. any ideas?

aide2001

  • Guest
Re: reCaptcha not working
« Reply #1 on: June 30, 2014, 10:19:32 pm »
In user-register.php check it to see if this line is in there
<?php osc_show_recaptcha(); ?>
somewhere after <?php osc_run_hook('user_register_form'); ?>

calidude38

  • Newbie
  • *
  • Posts: 10
Re: reCaptcha not working
« Reply #2 on: June 30, 2014, 10:55:19 pm »
Made the change but it still is not working.

aide2001

  • Guest
Re: reCaptcha not working
« Reply #3 on: June 30, 2014, 10:58:59 pm »
So was <?php osc_show_recaptcha(); ?> in the file??
if not your file should look like this
<?php
    /*
     *      Osclass – software for creating and publishing online classified
     *                           advertising platforms
     *
     *                        Copyright (C) 2013 OSCLASS
     *
     *       This program is free software: you can redistribute it and/or
     *     modify it under the terms of the GNU Affero General Public License
     *     as published by the Free Software Foundation, either version 3 of
     *            the License, or (at your option) any later version.
     *
     *     This program is distributed in the hope that it will be useful, but
     *         WITHOUT ANY WARRANTY; without even the implied warranty of
     *        MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
     *             GNU Affero General Public License for more details.
     *
     *      You should have received a copy of the GNU Affero General Public
     * License along with this program.  If not, see <http://www.gnu.org/licenses/>.
     */

    // meta tag robots
    osc_add_hook('header','bender_nofollow_construct');

    bender_add_boddy_class('register');
    osc_enqueue_script('jquery-validate');
    osc_current_web_theme_path('header.php') ;
?>
<div class="form-container form-horizontal form-container-box">
    <div class="header">
        <h1><?php _e('Register an account for free', 'bender'); ?></h1>
    </div>
    <div class="resp-wrapper">
        <form name="register" action="<?php echo osc_base_url(true); ?>" method="post" >
            <input type="hidden" name="page" value="register" />
            <input type="hidden" name="action" value="register_post" />
            <ul id="error_list"></ul>
            <div class="control-group">
                <label class="control-label" for="name"><?php _e('Name', 'bender'); ?></label>
                <div class="controls">
                    <?php UserForm::name_text(); ?>
                </div>
            </div>
            <div class="control-group">
                <label class="control-label" for="email"><?php _e('E-mail', 'bender'); ?></label>
                <div class="controls">
                    <?php UserForm::email_text(); ?>
                    <?php osc_show_recaptcha('register'); ?>
                </div>
            </div>
            <div class="control-group">
                <label class="control-label" for="password"><?php _e('Password', 'bender'); ?></label>
                <div class="controls">
                    <?php UserForm::password_text(); ?>
                </div>
            </div>
            <div class="control-group">
                <label class="control-label" for="password-2"><?php _e('Repeat password', 'bender'); ?></label>
                <div class="controls">
                    <?php UserForm::check_password_text(); ?>
                    <p id="password-error" style="display:none;">
                        <?php _e("Passwords don't match", 'bender'); ?>
                    </p>
                </div>
            </div>

<script type="text/javascript">
 var RecaptchaOptions = {
    theme : 'clean'
 };
</script><?php osc_run_hook('user_register_form'); ?>
<?php osc_show_recaptcha(); ?>
            <div class="control-group">
                <div class="controls">
                    <button type="submit" class="ui-button ui-button-middle ui-button-main"><?php _e("Create", 'bender'); ?></button>
                </div>
            </div>
        </form>
    </div>
</div>
<?php UserForm::js_validation(); ?>
<?php osc_current_web_theme_path('footer.php') ; ?>

calidude38

  • Newbie
  • *
  • Posts: 10
Re: reCaptcha not working
« Reply #4 on: July 01, 2014, 01:37:06 am »
No, it was not in the file. Is there a newer bender than 1.1.0?

aide2001

  • Guest
Re: reCaptcha not working
« Reply #5 on: July 01, 2014, 11:04:14 am »
No...but the newer bender has a problem in the common/head.php file also
You need to check line 4 or 5 in that file and it should have a    ;  at the end of the line
Search on here for bender theme not working and someone has already responded, or goto github and search bender theme osclass

adwriter

  • Newbie
  • *
  • Posts: 1
Re: reCaptcha not working
« Reply #6 on: August 01, 2014, 05:03:07 pm »
Hello - I am also facing similar problem... It is not letting users register saying 'reCaptcha not working' while its correct.. I am not versed with programing so that is also a problem.. Is any easier solution available to overcome this problem?

design

  • Hero Member
  • *****
  • Posts: 2632
  • Osclass 3.5 MAC/PC w/ Modern Browsers
Re: reCaptcha not working
« Reply #7 on: August 01, 2014, 07:41:01 pm »
yes bender 2. 0 is in the market!! don't download it from github

smcconnell

  • Newbie
  • *
  • Posts: 2
Re: reCaptcha not working
« Reply #8 on: November 01, 2015, 02:18:42 pm »
Was there any resolution to this?

My reCaptcha was working perfectly until recently, I have all automatic updates turned off (as far as I can see) and I haven't changed anything in the code since I added in the working reCaptcha.

I can see the reCaptcha form appear, so the keys are working and setup is fine, but I am getting a "The reCAPTCHA was not entered correctly" error message every time.

Any help would be appreciated.

Scott

avion99

  • Newbie
  • *
  • Posts: 3
Re: reCaptcha not working
« Reply #9 on: January 27, 2017, 05:45:08 pm »
I am also having same problem, I have input the private keys etc, but still not working, it keeps on saying "ERROR: Please solve Captcha correctly."

how do I fix it.