Advertisement:

Author Topic: Bug - first time language change  (Read 797 times)

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Bug - first time language change
« on: October 16, 2018, 09:48:55 pm »
Hey,

Bug - first time language change
step1: clear all your cookies, history, .. on your browser.
step2: install a fresh osclass with bender theme.
step3: install another language, for example spanish.
step4: buttom of the page click on spanish language.

as you can see language is still english. you have to click for the second time to change it to spanish.
 
is there a solution for this bug?

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #1 on: October 19, 2018, 08:58:18 pm »
Guys this is a serious bug. Lets fix this.
If users hit the languge and it doesn't change for the first time, they leave the website and never come back.

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 655
  • Best profile picture plugin ever is coming!
Re: Bug - first time language change
« Reply #2 on: October 20, 2018, 01:30:17 am »
Hello,

I suggest you post an issue on Osclass Github, it may help.
I don't know much about this bug or how to fix it (don't use more languages on my sites), but do a quick look on the code and see if I can find anything.

Regards.

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #3 on: October 20, 2018, 08:05:41 pm »
Hello,

I suggest you post an issue on Osclass Github, it may help.
I don't know much about this bug or how to fix it (don't use more languages on my sites), but do a quick look on the code and see if I can find anything.

Regards.

Thanks

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #4 on: October 26, 2018, 07:58:27 pm »
..., but do a quick look on the code and see if I can find anything.
Did you find a solution?

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 655
  • Best profile picture plugin ever is coming!
Re: Bug - first time language change
« Reply #5 on: October 26, 2018, 09:56:50 pm »
Nothing yet actually...
Does this happen the only on first visit or every first time you change the language? Can you test on unajmime.com.hr (my new site, click on "Hrvatski" in the header)?

Regards.

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #6 on: February 05, 2019, 12:12:52 pm »
Nothing yet actually...
Does this happen the only on first visit or every first time you change the language? Can you test on unajmime.com.hr (my new site, click on "Hrvatski" in the header)?

Regards.

Only on first visit
I don't know why osclass team dosnt care about this issue

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2086
  • osclass.work
Re: Bug - first time language change
« Reply #7 on: February 05, 2019, 12:51:36 pm »
Hi, it's related to your hosting/server environment, not Osclass.
Language selection is stored in sessions, so check with your hosting support what's happening. It can be many different things.

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #8 on: February 07, 2019, 10:21:39 pm »
Hi, it's related to your hosting/server environment, not Osclass.
Language selection is stored in sessions, so check with your hosting support what's happening. It can be many different things.

Hi there,
Thanks for replying,
No, this is related to osclass. Session is working perfectly in my host and website. Please test step by step that i explained in my first post and see the result.
Thanks

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2086
  • osclass.work
Re: Bug - first time language change
« Reply #9 on: February 08, 2019, 12:07:45 am »
does it work for you here: http://osclass.work/ ? (languages are all the way down in Bender)

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #10 on: February 08, 2019, 12:55:36 am »
does it work for you here: http://osclass.work/ ? (languages are all the way down in Bender)

That website has ajax. It doesnt show the correct test.
Please download new osclass3.7.4 with default bender theme and install a new langauge. When you are done without clicking on anywhere just click on a new langauge. You will see that language is still english. If you click on a new langauge for the second time then it changes to new language.
Please test step by step that i explained and see the result.
Thanks

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2086
  • osclass.work
Re: Bug - first time language change
« Reply #11 on: February 08, 2019, 01:23:03 am »
That code is managed separately and has absolutely nothing with languages. You can try any other page (e.g. search or item/ad) if you are bothered with. Does it work?

Also, Osclass 3.7.4 should not be used, as many bugs were fixed in 3.8.0, but as far as I can remember, it also works fine for languages.

Anyway, I have installed 3.7.4 and languages work properly with cleared cookies (what history has to do with it??). Have you tried this on a different server, hosting, localhost, different browser and computer?

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #12 on: February 08, 2019, 02:48:51 am »
That code is managed separately and has absolutely nothing with languages. You can try any other page (e.g. search or item/ad) if you are bothered with. Does it work?

Also, Osclass 3.7.4 should not be used, as many bugs were fixed in 3.8.0, but as far as I can remember, it also works fine for languages.

Anyway, I have installed 3.7.4 and languages work properly with cleared cookies (what history has to do with it??). Have you tried this on a different server, hosting, localhost, different browser and computer?

Please give me couple days to test on different servers and let you know. Im on phone these days. Thank you very much for helping.

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2086
  • osclass.work
Re: Bug - first time language change
« Reply #13 on: February 08, 2019, 08:04:50 am »
Make sure that you use clean browser installation, and that it is configured to accept cookies, does not remove them etc. Also, browser extensions can interfere, even some anti-virus software.

Sophia_OS

  • Full Member
  • ***
  • Posts: 224
Re: Bug - first time language change
« Reply #14 on: February 08, 2019, 10:35:17 pm »
Make sure that you use clean browser installation, and that it is configured to accept cookies, does not remove them etc. Also, browser extensions can interfere, even some anti-virus software.

@dev101,
i tested my osclass on different servers and localhost but still the same thing,
but i downloaded new osclass.3.7.4 and osclass.3.8.0 and tested and worked good!
what is wrong with my osclass? how can i find and fix this?