Advertisement:

Author Topic: Bug - first time language change  (Read 387 times)

Sophia_OS

  • Full Member
  • ***
  • Posts: 146
Bug - first time language change
« on: October 16, 2018, 09:48:55 pm »
Hey,

Bug - first time language change
step1: clear all your cookies, history, .. on your browser.
step2: install a fresh osclass with bender theme.
step3: install another language, for example spanish.
step4: buttom of the page click on spanish language.

as you can see language is still english. you have to click for the second time to change it to spanish.
 
is there a solution for this bug?

Sophia_OS

  • Full Member
  • ***
  • Posts: 146
Re: Bug - first time language change
« Reply #1 on: October 19, 2018, 08:58:18 pm »
Guys this is a serious bug. Lets fix this.
If users hit the languge and it doesn't change for the first time, they leave the website and never come back.

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 536
  • Can't advertise my site here...
Re: Bug - first time language change
« Reply #2 on: October 20, 2018, 01:30:17 am »
Hello,

I suggest you post an issue on Osclass Github, it may help.
I don't know much about this bug or how to fix it (don't use more languages on my sites), but do a quick look on the code and see if I can find anything.

Regards.

Sophia_OS

  • Full Member
  • ***
  • Posts: 146
Re: Bug - first time language change
« Reply #3 on: October 20, 2018, 08:05:41 pm »
Hello,

I suggest you post an issue on Osclass Github, it may help.
I don't know much about this bug or how to fix it (don't use more languages on my sites), but do a quick look on the code and see if I can find anything.

Regards.

Thanks

Sophia_OS

  • Full Member
  • ***
  • Posts: 146
Re: Bug - first time language change
« Reply #4 on: October 26, 2018, 07:58:27 pm »
..., but do a quick look on the code and see if I can find anything.
Did you find a solution?

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 536
  • Can't advertise my site here...
Re: Bug - first time language change
« Reply #5 on: October 26, 2018, 09:56:50 pm »
Nothing yet actually...
Does this happen the only on first visit or every first time you change the language? Can you test on unajmime.com.hr (my new site, click on "Hrvatski" in the header)?

Regards.