Loading


Advertisement:

Author Topic: Enabling Permalinks  (Read 167 times)

Sophia_OS

  • Jr. Member
  • **
  • Posts: 61
Enabling Permalinks
« on: September 22, 2017, 12:30:40 am »
Hi,

when i enable Permalinks in Admin->Settings->Permalinks, i would have these two problems:

1st problem: when i click on items that has chinese language, Item Title with chinese language appears in URL and get (Bad Request 403 Forbidden error)
2nd problem: when i search by location, state and city with chinese language appears in URL and get (Bad Request 403 Forbidden error)

i tried to solve that, but i couldn't. somebody told me set "RewriteUrls" OFF in htaccess file, but i couldn't find the correct code.

that's why i tried to solve in other way by changing the URL formats in Admin->Settings->Permalinks->Show-rules
here i solved the 1st problem by changing the value of "Listing URL:" to "{CATEGORIES}/i{ITEM_ID}" and it worked perfectly when i click on items.
for the 2nd problem i couldn't find a place to change the url format not to appear in search url

Please help me to solve this problem

Thank you
 

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5355
  • Hardliner
Re: Enabling Permalinks
« Reply #1 on: September 22, 2017, 12:45:24 pm »
Friendly urls on and off  (turn it to off). Also you have removed the item title, so why enable permalinks after all ? For the Category and a number ? No reason.

« Last Edit: September 22, 2017, 12:50:45 pm by Aficionado »

Sophia_OS

  • Jr. Member
  • **
  • Posts: 61
Re: Enabling Permalinks
« Reply #2 on: September 22, 2017, 06:42:21 pm »
@Aficionado
Friendly urls on and off  (turn it to off): because i need permalinks for public profile.
Also you have removed the item title, so why enable permalinks after all? i just need permalinks for public profile.
Thank you

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 5355
  • Hardliner
Re: Enabling Permalinks
« Reply #3 on: September 22, 2017, 06:47:33 pm »
@Aficionado
Friendly urls on and off  (turn it to off): because i need permalinks for public profile.
Also you have removed the item title, so why enable permalinks after all? i just need permalinks for public profile.
Thank you

Apparently we can't communicate right or you have no idea what you are talking about. You asked how to turn permalinks to off and i replied.

Also permalinks for public profile is something nobody cares. Useless totally.

Anyway good luck with your site.

Sophia_OS

  • Jr. Member
  • **
  • Posts: 61
Re: Enabling Permalinks
« Reply #4 on: September 22, 2017, 07:10:16 pm »
@Aficionado
Friendly urls on and off  (turn it to off): because i need permalinks for public profile.
Also you have removed the item title, so why enable permalinks after all? i just need permalinks for public profile.
Thank you

Apparently we can't communicate right or you have no idea what you are talking about. You asked how to turn permalinks to off and i replied.

Also permalinks for public profile is something nobody cares. Useless totally.

Anyway good luck with your site.

@Aficionado
i did not ask how to turn off permalinks my friend, i said i have problem when i turn on permalinks  :)
i do need public profiles to be permalinks for some reason,
do you know how to enable just public profile permalinks by editing core?
thank you
« Last Edit: September 22, 2017, 10:40:42 pm by Sophia_OS »

Sophia_OS

  • Jr. Member
  • **
  • Posts: 61
Re: Enabling Permalinks
« Reply #5 on: September 22, 2017, 10:46:05 pm »
anybody knows?

how to enable just public-profile permalinks by editing core?
how to set normal url (URLs which have question marks and lots of numbers in them) be default after enabling permalinks?