Advertisement:

Author Topic: ssl issues with osclass  (Read 693 times)

davidn

  • Newbie
  • *
  • Posts: 15
ssl issues with osclass
« on: February 07, 2019, 04:42:11 pm »
please, i installed ssl to my site, but it did not change to https.
i tried forcing http  to  https, my site css now scattered.

what should i do?

my site is https://worldmarketsquare.com

Thanks

aide2006

  • Newbie
  • *
  • Posts: 16
Re: ssl issues with osclass
« Reply #1 on: February 07, 2019, 05:03:45 pm »
Did you also change your config file, and or in admin suggest using ssl?

davidn

  • Newbie
  • *
  • Posts: 15
Re: ssl issues with osclass
« Reply #2 on: February 08, 2019, 01:35:23 am »
I used cloudflare to force https;

although  i still get warnings that my images are not secured...

please, how do i change my config file?

aide2006

  • Newbie
  • *
  • Posts: 16
Re: ssl issues with osclass
« Reply #3 on: February 11, 2019, 04:29:56 pm »
if you get to your orginal files
then in the very first config.php
locate this
define('WEB_PATH', 'YOUR WEBSITE ADDRESS/');

with
define('WEB_PATH', 'https://yourwebsite_address/');

Aficionado

  • Guest
Re: ssl issues with osclass
« Reply #4 on: February 11, 2019, 06:59:46 pm »
I used cloudflare to force https;

although  i still get warnings that my images are not secured...

please, how do i change my config file?

I don't really get the Cloudflare installation on a new and empty site.

Anyway, you seem to have other problems also, selecting a Country from the dropdown menu DOESN'T change/reflect any REGION listing of that Country.


mladja04

  • Jr. Member
  • **
  • Posts: 91
Re: ssl issues with osclass
« Reply #5 on: March 16, 2019, 09:43:50 pm »
Hi, I have same problem, and because that I open again this thread.

I know that is possible to in this config.php line write site url only with first lines //, to be

define('WEB_PATH', '//www.mysite.com/');

And with this setting work both, http and https.

Do this is OK, to put only // without http or https in from of link?

Thank you.

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2177
  • osclass.work
Re: ssl issues with osclass
« Reply #6 on: March 17, 2019, 02:14:19 am »
It's OK, but these days it's best to force https and redirect http.

mladja04

  • Jr. Member
  • **
  • Posts: 91
Re: ssl issues with osclass
« Reply #7 on: March 17, 2019, 03:07:40 am »
Thank you. I will do that, in some next period. Very soon.