Advertisement:

Author Topic: Instalo y activo idioma en español pero no se traduce  (Read 340 times)

davidblack

  • Newbie
  • *
  • Posts: 1
Instalo y activo idioma en español pero no se traduce
« on: October 23, 2018, 09:57:56 am »
Hola,

Instalo y activo idioma en español pero no se traduce en la web aunque seleccione el idioma español.

Para ello he seguido paso a paso lo indicado en este vídeo:

https://www.youtube.com/watch?v=YZOK_MpD1qc

GRacias

Xefiron

  • Newbie
  • *
  • Posts: 32
  • Software developer - Desarrollador de software
Re: Instalo y activo idioma en español pero no se traduce
« Reply #1 on: March 27, 2019, 07:49:50 pm »
Saludos, se que el tema es antiguo, pero espero esto de luces a quienes tengan este mismo problema en el futuro.

Estos vendrían a ser los pasos a seguir en caso de que sus temas aún no se traduzcan al español aún cuando ya lo instalaron, activaron, pusieron como idioma por defecto y reiniciaron la sesión de administrador.

  • Abran la carpeta dónde tienen instalado el Osclass. (Si usan XAMPP, dentro de la carpeta htdocs\[nombre_de_su_proyecto])
  • Sigan la siguiente ruta \oc-content\themes\[tu_tema_activo]\languages
  • Dentro de esa carpeta están las carpetas de los idiomas disponibles de su tema

Lo normal es que dentro de la carpeta uno esperase encontrarse a lo menos dos carpetas, una llamada en_US y la otra es_ES. Pero como no todos los desarrolladores hablan español, a veces no encontraras la carpeta es_ES. Por lo que solo hace falta crear una traducción del tema a nuestro idioma. Para eso pueden dirigirse al siguiente enlace de Osclass en el que indican como hacerlo:

https://blog.osclass.org/2014/09/05/translate-osclass-plugins-themes/

Nota: Estas instrucciones también te ayudaran para averiguar si tus plugins estan traducidos, y también puedes traducirlos de la misma manera. Espero esto te sea de ayuda, saludos.