Advertisement:

Author Topic: [Résolu] Annonce non accessible...  (Read 1630 times)

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
[Résolu] Annonce non accessible...
« on: February 08, 2014, 01:26:09 pm »
Bonjour à tous,

J'ai un petit problème...

Lorsqu'un utilisateur poste une annonce, une fois validée, celui-ci (normalement) est redirigé vers la page de son annonce (avec un bandeau "un administrateur validera l'annonce" (ou quelque chose comme ça !!!))...
Mais dans mon cas il est redirigé vers la page 404...
De ce fait il ne vois pas son annonce et à tendance à reposter cette annonce (et je me retrouve avec 4,5 mêmes annonces à valider...)

De même lorsque je reçois le mail "d'ajout d'une nouvelle annonce", j'ai l'URL de cette annonce dans le mail...
Si je clique dessus, je suis redirigé sur la page 404...

Si je vais dans l'Admin et que je clique sur le lien, alors là... je suis bien dirigé sur cette annonce (avec le bandeau "à valider")
Et une fois validé, bien sur cette annonce devient accessible...

Je vous invite à poster une annonce afin de vous rendre compte par vous même de ce problème (SVP mettre ESSAI dans votre annonce, que je puisse l'effacer par la suite).

Comment puis-je remédier à cet problème ?

Merci de votre aide

Cordialement
« Last Edit: March 03, 2014, 12:40:06 pm by Nicolas30 »

romantica

  • Premium
  • Hero Member
  • *****
  • Posts: 1092
  • salut tout le monde
Re: Annonce non accessible...
« Reply #1 on: February 08, 2014, 05:01:24 pm »
salut dans ta page debug ça donne quoi? a tu ajouté un plugin dernièrement? tu a deux pistes possibles et encore a tu fait la mise a jour de osclass?
ciao

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #2 on: February 08, 2014, 07:38:13 pm »
Salut Romantica,
salut dans ta page debug ça donne quoi?
La page debug ??? et tu la trouve ou cette page ?

a tu ajouté un plugin dernièrement?
Bin dernierement... non...

Je viens de désactiver plusieurs plugins, je fais un essai et je reviens...

Cdt

Edit: après avoir désactivé plusieurs plugins, cela semble remarcher...
« Last Edit: February 08, 2014, 07:43:33 pm by Nicolas30 »

romantica

  • Premium
  • Hero Member
  • *****
  • Posts: 1092
  • salut tout le monde
Re: Annonce non accessible...
« Reply #3 on: February 09, 2014, 12:42:32 am »
installe un par un les plugins et tu vérifier  au for et au mesure,et tu va trouver le fautif !
pour le debug:
/**
 *Copir le code dans ta config.php
 * This will log all error notices and warnings to a file called debug.log in oc-content
 */
define('OSC_DEBUG', true) ;
define('OSC_DEBUG_LOG', true)
;
ciao
« Last Edit: February 09, 2014, 01:02:56 am by romantica »

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #4 on: February 09, 2014, 05:20:02 pm »
Re,
Le problème persiste...

J'ai été prévenu par un posteur, que celui-ci était redirigé sur la page 404 après validation de son annonce...

Pour ma part cette annonce est bien là, je la valide (moreedit) et le lien redeviens actif...
Idem pour le mail de validation, le posteur est dirigé sur la page 404, si il veux modifier ou effacer son annonce, il ne peut donc pas (???)

Une idée ?

Cdt

romantica

  • Premium
  • Hero Member
  • *****
  • Posts: 1092
  • salut tout le monde
Re: Annonce non accessible...
« Reply #5 on: February 09, 2014, 07:41:48 pm »
salut copie le code sur config.php et apres dans oc content tu trouves debug log ici ti peut voir l'erreur!
bon travail

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #6 on: February 22, 2014, 10:43:04 pm »
J'ai tout simplement retirer les "permaliens" et cela remarche...

Cdt

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #7 on: February 26, 2014, 08:49:25 pm »
Bon en définitif le problème n'est pas résolu...

Je n'ai rien de suspect dans mon fichier "debug.log"...

Je ne sais vraiment pas d'ou cela peut venir...   >:(

Une aide urgente serais la bien venue...

Vous remerciant

Cdt

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #8 on: February 28, 2014, 01:25:12 pm »

Nicolas30

  • Sr. Member
  • ****
  • Posts: 295
Re: Annonce non accessible...
« Reply #9 on: March 03, 2014, 12:39:46 pm »
Bon en fait j'ai solutionné mon problème, pas comme je le voudrais mais bref, je n'ai plus la redirection vers la page 404...

Au bas du fichier "function.php" de mon thème, j'avais rajouté :
 function redirect_to_landing($item) {
        osc_get_static_page('publish_ok');
        header( 'Location: ' .
osc_item_url() ); exit;
    }
    osc_add_hook('posted_item', 'redirect_to_landing');


J'ai tout simplement changé comme ceci :
function redirect_to_landing($item) {
        osc_get_static_page('publish_ok');
        header( 'Location: ' .
osc_base_url() ); exit;
    }
    osc_add_hook('posted_item', 'redirect_to_landing');


Ce qui redirige (après post de l'annonce) vers la page d'accueil...

Cdt
« Last Edit: March 03, 2014, 12:44:36 pm by Nicolas30 »