Loading


Advertisement:

Author Topic: A BIG problem with custom attributes in search bar  (Read 196 times)

NotNight999

  • Newbie
  • *
  • Posts: 16
A BIG problem with custom attributes in search bar
« on: March 20, 2017, 11:07:07 pm »
I have a problem with custom attributes.

 Neither plagin (custom attributes) works correct nor osclass`s custom attributes. When I add more than 1 custom field in search bar it becomes unsearchable by using this custom fields. Precisely speaking  I can not use more than 1 custom field both at once.

How I can turn around it?

Thanks
« Last Edit: March 20, 2017, 11:10:57 pm by NotNight999 »

NotNight999

  • Newbie
  • *
  • Posts: 16
Re: A BIG problem with custom attributes in search bar
« Reply #1 on: March 22, 2017, 01:38:35 pm »
What I need to do? Anybody knows?

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4449
Re: A BIG problem with custom attributes in search bar
« Reply #2 on: March 22, 2017, 02:26:42 pm »
Which version of Osclass are you using?
Any plugins?
What do you mean unsearchable?
Did you enabled PHP debug ? https://doc.osclass.org/Debug_PHP_errors
And SQL debug? https://doc.osclass.org/Debug_SQL_queries
Is there any error or just no results?
Are the queries failing?

In order to get help, please provide more information about your issue, it's too vague.

NotNight999

  • Newbie
  • *
  • Posts: 16
Re: A BIG problem with custom attributes in search bar
« Reply #3 on: March 24, 2017, 01:52:36 pm »
Osclass 3.7.1
Yes, many plagins. Occasionally delet and install again.
More than 1 custom field it dont want to search.
I have just put PHP and SQL debug code into config.php and it writes in debug plagin that -  PHP Warning: urldecode() expects parameter 1 to be string, array given in /var/www/vh172156/data/www/waiffind.com/board/oc-includes/osclass/classes/Rewrite.php on line 192

What can I do?

« Last Edit: March 24, 2017, 01:55:21 pm by NotNight999 »

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4449
Re: A BIG problem with custom attributes in search bar
« Reply #4 on: March 24, 2017, 01:56:45 pm »
Is there any url where we could see your issue?
which theme are you using?
which plugins are you using?

NotNight999

  • Newbie
  • *
  • Posts: 16
Re: A BIG problem with custom attributes in search bar
« Reply #5 on: March 24, 2017, 02:12:43 pm »
Now I use OsclassWizards 2.0.4 theme

And plagins from below

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4449
Re: A BIG problem with custom attributes in search bar
« Reply #6 on: March 24, 2017, 02:14:48 pm »
Are you using the custom attributes plugin ??
Are you having issues with THAT plugin? then contact the author, but I think the plugin is/was outdated.

There are custom attributes already in Osclass core, so not sure why use a plugin for that...

NotNight999

  • Newbie
  • *
  • Posts: 16
Re: A BIG problem with custom attributes in search bar
« Reply #7 on: March 24, 2017, 02:17:32 pm »
The Osclass custom attributes has the same issue. Custom attributes do not work neither in osclass nor in the plagin.

_CONEJO

  • Administrator
  • Hero Member
  • *****
  • Posts: 4449
Re: A BIG problem with custom attributes in search bar
« Reply #8 on: March 24, 2017, 02:39:18 pm »
Without any more information we are not able to help you further, we are not able to reproduce the issue, as still we are not sure what the issue is
What means "unsearchable"? no results? white page? which url is giving you problems?
Did you modify any file? which custom fields are you using?

Please add as many information as possible.

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1578
  • osclass.work
Re: A BIG problem with custom attributes in search bar
« Reply #9 on: March 24, 2017, 03:54:59 pm »
Could be a problem with cyrillic characters and missing slugs, check that your custom fields slugs use latin characters.

NotNight999

  • Newbie
  • *
  • Posts: 16
Re: A BIG problem with custom attributes in search bar
« Reply #10 on: March 30, 2017, 03:09:07 pm »
There is an error in search bar in custom attributes as in osclass custom fields as well in plagin custom attributes. PHP bag plagin displays that

Code: [Select]
PHP Warning: urldecode() expects parameter 1 to be string, array given in /var/www/vh172156/data/www/waiffind.com/board/oc-includes/osclass/classes/Rewrite.php on line 192
Who faced with this issue? Can you give a hand of help