Advertisement:

Author Topic: default bender - debug error  (Read 194 times)

Sophia_OS

  • Sr. Member
  • ****
  • Posts: 408
default bender - debug error
« on: April 15, 2019, 11:32:17 pm »
why i'm getting this error when i activate my debug error?
this is a default bender theme!
is everyone getting this?

config file:
define('OSC_DEBUG', true) ;

error shows only on search.php page:
Code: [Select]
Warning: Illegal string offset 'pk_i_id' in /***/oc-content/themes/bender/search-sidebar.php on line 23 Warning: Cannot assign an empty string to a string offset in /***/oc-content/themes/bender/search-sidebar.php on line 23

search-sidebar.php -> line 23
Code: [Select]
     $category = __get("category");
     if(!isset($category['pk_i_id']) ) {
         $category['pk_i_id'] = null;
     }

Sophia_OS

  • Sr. Member
  • ****
  • Posts: 408
Re: default bender - debug error
« Reply #1 on: April 19, 2019, 02:11:40 am »
do you all get this error!
because i tested it with default bender!

bayamselam

  • Newbie
  • *
  • Posts: 4
Re: default bender - debug error
« Reply #2 on: April 19, 2019, 04:13:06 am »
Its because you tried an empty search
You have to comment the line 23. And the error will go. But when you do emprty search it will expose the token and the url.

Sophia_OS

  • Sr. Member
  • ****
  • Posts: 408
Re: default bender - debug error
« Reply #3 on: April 19, 2019, 04:56:31 am »
@bayamselam
i tried both with-value or empty search and i got this error!
search.php page works good! i just get this error when i activate debug in config.php
i think in this code it can't get category value = $category = __get("category");