Advertisement:

Author Topic: email configuration  (Read 719 times)

HalbertF

  • Newbie
  • *
  • Posts: 4
email configuration
« on: December 20, 2018, 01:46:18 am »
Hi everyone, I'm Alberto from Italy.
I have followed and read several tutorials. I have configured following the instructions but I don't understand why sending emails doesn't work.
Where am I wrong?

hostname: smtp.gmail.com
port: 465
user: myuser without @google.com
ssl
yes SMTP is enabled

I don't receive emails.

Can someone help me?

marius-ciclistu

  • issues
  • Hero Member
  • *
  • Posts: 1618
  • "BE GRATEFUL TO THOSE THAT SUPPORTED YOU"
Re: email configuration
« Reply #1 on: December 20, 2018, 08:08:09 am »
Search the forum for this topic. :)) many people complain about gmail not working, so go with your host mail server.

HalbertF

  • Newbie
  • *
  • Posts: 4
Re: email configuration
« Reply #2 on: December 20, 2018, 03:30:30 pm »
Hi marius-ciclistu, thank you for your help.
Unfortunately also with my configuration the system doesn't send.
I tested also localhost.

Aficionado

  • Guest
Re: email configuration
« Reply #3 on: December 20, 2018, 03:47:10 pm »
Hi marius-ciclistu, thank you for your help.
Unfortunately also with my configuration the system doesn't send.
I tested also localhost.

This not related to Osclass but of your hosting provider or server setup. Ask them how to do that and what to use. Email with Osclass works pretty well (apart from Gmail that doesn't because mainly of gmail and not Osclass, still a bad choice).
« Last Edit: December 20, 2018, 04:22:00 pm by Aficionado »

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 698
  • OSC Market review time makes me wanna cry...
Re: email configuration
« Reply #4 on: December 20, 2018, 07:41:17 pm »
Still don't get this. Mail on Osclass works great on my hosting without touching anything in the Osclass settings. And yes, I have shared and pretty cheap hosting...
Try creating a mail address at your cPanel and enter the data you get to Osclass mail settings, DON'T use Gmail - it's not meant to be used so.

Regards.

Aficionado

  • Guest
Re: email configuration
« Reply #5 on: December 20, 2018, 08:08:00 pm »
Still don't get this. Mail on Osclass works great on my hosting without touching anything in the Osclass settings. And yes, I have shared and pretty cheap hosting...


What makes me furious, is the fact that Osclass team doesn't remove this Gmail option. And that just complicates things for new people using Osclass. Not everyone understands that Gmail is not designed as an smtp server.

HalbertF

  • Newbie
  • *
  • Posts: 4
Re: email configuration
« Reply #6 on: December 21, 2018, 12:23:27 am »
Hi guys, thanks for your help Aficionado and patrickFromCroatia.
I think the problem is the dns.

patrickFromCroatia

  • Hero Member
  • *****
  • Posts: 698
  • OSC Market review time makes me wanna cry...
Re: email configuration
« Reply #7 on: December 21, 2018, 01:25:32 am »
Hi guys, thanks for your help Aficionado and patrickFromCroatia.
I think the problem is the dns.

I don't think DNS is the issue if you are not using your hosting's email but Gmail.
 BTW shouldn't this "user: myuser without @google.com" be "user: myuser without @gmail.com"?

Regards.

HalbertF

  • Newbie
  • *
  • Posts: 4
Re: email configuration
« Reply #8 on: December 22, 2018, 06:26:28 pm »
Hi, I found the "problem" and I share it.
If you install a different language when you access email templates and press "edit" if you do not complete templates with tags, these do not work. It works correctly if you complete it! It's logical! but it took me a while to understand it. :o