Loading


Advertisement:

Author Topic: Osclass 3 installation Errors  (Read 378 times)

SmaRTeY

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2371
Re: Osclass 3 installation Errors
« Reply #15 on: July 11, 2017, 11:29:35 pm »
Thanks for your comments here _CONEJO.
Personally I think it's about preventing complaints and with little effort we can achieve better user experience I think/hope.
Some questions will never 'die' because people (like myself) act before they read and run into trouble they could have prevented reading up front. However, if important info is missing when people do read up front it all stops so therefor my pledge to include some kind of simple doc with min. yet needed requirements to install Osclass disabling people from accusing of missing info.

I will start writing something and share it for review and additions/corrections so we'll end up with something simple/basic to include.
Whatever comes to mind I will try to mention. So including 'tips' about email setup and references among other.

Regards,
Eric



Imo this also is needed for email requirements per possible mail host based on what we know already thanks to forum posters.

True. For example we do know that the default GMAIL option should be removed.

AFAIK, gmail is not the default option, it's the local server : https://github.com/osclass/Osclass/blob/master/oc-includes/osclass/installer/basic_data.sql#L48
which in most cases (shared/managed) should work out of the box, but people using VPS is more and more common, without configuring/installing a proper email server, we probably should remove it, but people will complain anyway that the emails are not working.


@_CONEJO, in case you are reading this, do you agree?

I have some time available (unfortunately) and can start a doc based on what I know/find but I would need the confirmation this doc will be added to future download packages of Osclass.

I'm not sure people read any file before installing any software, requirements are not that much, we may need to include in the installer, but if you do it, we'll include it in the download/package.




im trying to reinstall it but always shows same error of mbstring so how to clear this error please when i cantact my host company they told that "i already informed contact your developer and change mbstring module"

mbstring is requried by Osclass, you need to install and enable it in your server, you can not "clear" the error without installing and enabling the mbstring extension.

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1704
  • osclass.work
Re: Osclass 3 installation Errors
« Reply #16 on: July 12, 2017, 04:11:12 am »

SmaRTeY

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2371

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 4634
  • Hardliner
Re: Osclass 3 installation Errors
« Reply #18 on: July 13, 2017, 03:52:35 pm »
Not an issue. Actually it is an Osclass feature. It keeps you away from CRAPPY hosting OR from un-managed hosting that you have NO IDEA how-to (and come crying here for help).

It shouldn't be changed. Something will be always missing, some graphics lib, or whatever ....

If Osclass users START with a wrong hosting decision, they will never reach the next stage. So Osclass team better focus into noticing to new users how important a good hosting plan is.

Please do not bother to hit me with replies about how wrong i'm, i don't care for your opinions. Especially from people that do not run a long-time high traffic Osclass service.
« Last Edit: July 13, 2017, 03:58:50 pm by Aficionado »

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1704
  • osclass.work
Re: Osclass 3 installation Errors
« Reply #19 on: July 13, 2017, 03:58:17 pm »
dependencies / requirements must be stated before/during installation steps, that's what all scripts do. It has nothing to do with "crappy hosting" thing.

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 4634
  • Hardliner
Re: Osclass 3 installation Errors
« Reply #20 on: July 13, 2017, 04:01:09 pm »
dependencies / requirements must be stated before/during installation steps, that's what all scripts do. It has nothing to do with "crappy hosting" thing.

Can you point to to one "script" that does what you say ?

Wordpress for example ? Because i only see:

https://wordpress.org/about/requirements/

or

https://www.drupal.org/docs/7/system-requirements

or

https://downloads.joomla.org/technical-requirements

« Last Edit: July 13, 2017, 04:02:45 pm by Aficionado »

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1704
  • osclass.work
Re: Osclass 3 installation Errors
« Reply #21 on: July 13, 2017, 04:09:01 pm »
There are scripts that perform tons of checks during installations, it is pointless to post links to all of them, as many do not list complete list of requirements until you actually start installation process -- but they do perform various checks and give a feedback to the end user. It's called 'system check' step and it is a valuable user experience. Osclass already does this well, just missing this step, which is important, because installation will fail in the middle of it with "white page of death" and inexperienced users might not realize they'll have to check php error logs to understand what just happened.

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 4634
  • Hardliner
Re: Osclass 3 installation Errors
« Reply #22 on: July 13, 2017, 04:27:44 pm »
There are scripts that perform tons of checks during installations, it is pointless to post links to all of them, as many do not list complete list of requirements until you actually start installation process -- but they do perform various checks and give a feedback to the end user. It's called 'system check' step and it is a valuable user experience. Osclass already does this well, just missing this step, which is important, because installation will fail in the middle of it with "white page of death" and inexperienced users might not realize they'll have to check php error logs to understand what just happened.

Crappy hosting is all about it is.

In a proper hosting company most modules come installed/enabled like curl etc etc. And in the case that something exotic is not installed, a ticket to the support solves that in a few minutes.

So again, it is all about hosting.

It is impossible for a script to check everything, and i haven't found any that does it yet.

But, as i said, your opinion is an opinion of a developer. Important for things related to that. Imagine myself, to start saying things about how good some php code is.

 ;)

(crappy hosting means for example Hosting Companis that don't/won't setup well their TMP files folder for example, and people have session problems).
« Last Edit: July 13, 2017, 04:34:37 pm by Aficionado »

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1704
  • osclass.work
Re: Osclass 3 installation Errors
« Reply #23 on: July 13, 2017, 04:34:00 pm »
I think that you're missing the point. As someone posted already an answer, Osclass is using a non-default extension, unlike vanilla WordPress that does and will work with most newer PHP versions "out of the box". In those cases, when you use something which is not default, must be included in the requirements.

Also, enabling a lot of unnecessary extensions just because you can, does not mean it's smart. In fact, in my opinion, a good shared hosting will initially provide you only with vanilla php version, and later enable you to customize/expand it per your needs. There are 100s of extensions out there, do you (your hosting) really have them all enabled? I doubt it.

Anyway, it is a pointless discussion really, as the fix is already proposed and requires minimal changes in a single file.

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 4634
  • Hardliner
Re: Osclass 3 installation Errors
« Reply #24 on: July 13, 2017, 04:39:17 pm »
I think that you're missing the point. As someone posted already an answer, Osclass is using a non-default extension, unlike vanilla WordPress that does and will work with most newer PHP versions "out of the box". In those cases, when you use something which is not default, must be included in the requirements.

Also, enabling a lot of unnecessary extensions just because you can, does not mean it's smart. In fact, in my opinion, a good shared hosting will initially provide you only with vanilla php version, and later enable you to customize/expand it per your needs. There are 100s of extensions out there, do you (your hosting) really have them all enabled? I doubt it.

Anyway, it is a pointless discussion really, as the fix is already proposed and requires minimal changes in a single file.

it is a poinless discussion, yes. because something will alsways be missing. CURL/MBSTRING/Sessions not saving/PHP 5.3, you name it.

Things that are solved very quickly by ANY decent support in a company.

Anyway, i think Osclass should also check (somehow) if the Hosting company is FREE (and decline) and also if the Hosting Plan costs 1 Dollar per month and also decline.

 ;D

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1704
  • osclass.work
Re: Osclass 3 installation Errors
« Reply #25 on: July 13, 2017, 04:45:04 pm »
Osclass will run without cURL, because it has (for the time being) a fallback library as part of the core. In fact, Osclass has a lot of libraries as fallback/compatibility backups, so your argument is non-existent. Sessions paths/issues are usually permissions/hosting related, not installation related.

edit: as I know there are plans to cleanup core from old libraries at some point, the checks during installation step must be updated to reflect those non-standard requirements (such as support for zip, cURL, etc.), because there will be no fallback to rely upon anymore.
« Last Edit: July 13, 2017, 04:54:48 pm by dev101 »