Loading


Advertisement:

Author Topic: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha  (Read 1089 times)

rammohan.reddy

  • Newbie
  • *
  • Posts: 15
ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« on: January 07, 2017, 08:45:17 am »
Hi Team,

Currently am using OSclass 3.6.1 & noCaptcha reCaptcha 1.2.1.Same configured in Modern theme 5.1.

Capcha image visible clearly and also we are entering captcha correctly but still it is giving below error.

ERROR: Please solve Captcha correctly.

Anyone could you please help me to resolve this issue.

Note : Am adding below code before submit button.
<?php osc_run_hook("anr_captcha_form_field"); ?>

Thank You,
Regards
Rammohan

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1782
  • osclass.work
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #1 on: January 08, 2017, 12:48:08 am »
Plugin requires allow_url_fopen = On directive set in PHP config, your server probably does not have it enabled.

Alternatively, if you upgrade to 3.7.x you no longer need external plugin for v2 captcha API, it is supported inside the core and uses cURL library.

Regards

rammohan.reddy

  • Newbie
  • *
  • Posts: 15
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #2 on: January 09, 2017, 12:28:02 pm »
Hi Dev,

Thanks a Ton for you quick support. I will try to upgrade the version and will get back to you.

Thank You,
Regards
Rammohan

avion99

  • Newbie
  • *
  • Posts: 3
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #3 on: February 01, 2017, 10:13:35 pm »
I have tried all, but still doesn't work. Please advice

dev101

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 1782
  • osclass.work
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #4 on: February 04, 2017, 09:33:42 pm »
Hi acion99,

not sure if you installed fresh 371 version, or upgraded from the old one. If it is a fresh install, it should work. If you upgraded from an older version, then there could be a problem with the settings and you will have to manually delete the version from oc_t_preference table. Here is the screenshot with highlighted line:

https://github.com/osclass/Osclass/pull/2117

Then, go back to your admin settings and check "version 2" normally.

If it still does not work then, I am out of ideas.

Regards

MrWolf

  • Newbie
  • *
  • Posts: 10
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #5 on: February 07, 2017, 07:23:25 pm »

avion99

  • Newbie
  • *
  • Posts: 3
Re: ERROR: Please solve Captcha correctly - noCaptcha reCaptcha
« Reply #6 on: February 12, 2017, 12:38:58 am »
Hi acion99,

not sure if you installed fresh 371 version, or upgraded from the old one. If it is a fresh install, it should work. If you upgraded from an older version, then there could be a problem with the settings and you will have to manually delete the version from oc_t_preference table. Here is the screenshot with highlighted line:

https://github.com/osclass/Osclass/pull/2117

Then, go back to your admin settings and check "version 2" normally.

If it still does not work then, I am out of ideas.

Regards

I have reinstalled the osclass, but nocaptcha version still gives me the same error "The reCAPTCHA was not entered correctly".

Please advice