Advertisement:

Author Topic: [SOLVED] Osclass Payments Pro, external gateways not working properly  (Read 308 times)

edulopesf

  • Newbie
  • *
  • Posts: 6
If user chooses to buy a "Premium listing" (or any other service such as publish fee, move to top and etc..), even with a successful operation on Gateway website, the listing does not becomes premium. Also, nothing shows up on "History of payments". Basically, I can charge my customers and receive, but I can't provide the service because the plugin is not working as it should.

I have been testing on Paypal gateway on sandbox enviroment and made another few tests with PagSeguro gateway on both production and sandbox enviroment. Same issue.

-debug logs do not provide any error messages

-THE ONLY WORKING WAY IS TO USE "Bank Transfer with Wallet". With a topped-up wallet, the plugin does work. Sadly, if I choose to proceed this way, I'll have to manually check every single deposit/transfer and approve/decline one by one... 

-Tested with versions 3.8 and 3.7.4, same behaviour.

-After research on forum, looks like no one had the same issue, how can it be just me???? Where is my mistake?  :-[

-Could it be a hosting problem (hostgator)?

- A support message was sent, about a day ago, but i'm a little bit rushed and tought someone might help faster here...


 Thanks in advance for any support
« Last Edit: April 13, 2019, 10:33:35 pm by edulopesf »

edulopesf

  • Newbie
  • *
  • Posts: 6
Re: Osclass Payments Pro, external gateways not working properly
« Reply #1 on: April 12, 2019, 03:37:21 pm »
UPDATE!

After tests on production environment through Paypal, I had success.

So, the problem is isolated to "PagSeguro". I received the money but the plugin is not doind its job neither doind any sort of registration about the payment.

edulopesf

  • Newbie
  • *
  • Posts: 6
Re: Osclass Payments Pro, external gateways not working properly
« Reply #2 on: April 13, 2019, 10:32:04 pm »
SOLVED

It was my mistake on gateway setup.