Advertisement:

Author Topic: (Plugin) Ghostbuster 4.0  (Read 7506 times)

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #15 on: March 26, 2014, 12:48:50 pm »
Every hour sounds ok aswell, but that doesn't happen on my install... hmm
I have to run it manually.

Any ideas of how to fix? Re-install GhostBuster (remove/install) ?
Disable cron, refresh and enable?

Is there a way to see what/when cron runs?

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #16 on: March 26, 2014, 12:57:40 pm »
I un-installed GhostBuster 4.0, removed ./oc-content/plugins/ghost_fix/ and re-installed.
Will give feedback on outcome :)

These ghosts are pretty annoying... "The listing you are trying to delete couldn't be deleted"
but oh well..
« Last Edit: March 26, 2014, 03:27:47 pm by xilian »

SmaRTeY

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2520
Re: (Plugin) Ghostbuster 4.0
« Reply #17 on: March 26, 2014, 02:29:27 pm »
Hi Jay,

this plugin is superb and I am wondering, is there some logging which tells us the job ran every hour or is there another way to check this beside putting in a ghost ad?  ::)

Thanks!
Eric

Hi xilian,

This plugin runs hourly via the cron to check for ghost ads. There currently is no way to set it to run every 30 minutes but I think an hour is just fine. If you happen to be on and there seems to be a bunch of ghost ads just go to the Ghostbuster menu page and it will remove ghost ads.

Jay

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #18 on: March 26, 2014, 05:20:08 pm »
okay, been a couple of hours now since ghost was created on site, no auto-removal.
Manual removed instantly.

Conclusion: Ghost is not in cron :)

note:
I have "dev"-site up and running (direct copy of the live one) that I can give
access to if you wanna have a look.
« Last Edit: March 26, 2014, 05:25:25 pm by xilian »

trains58554

  • Osclass contributor
  • Hero Member
  • *****
  • Posts: 3642
  • osCanyon, the class of Osclass
Re: (Plugin) Ghostbuster 4.0
« Reply #19 on: March 26, 2014, 08:25:30 pm »
@xilian,

The built in cron only runs if you have visitors to the user side of your site. So that maybe why it is not running for you.

@SmaRTeY,

There is some logging but currently the only way to see it is by looking in the db in the table t_log as that is the same log as osclass uses.

@Aficionado,

In my last post I stated it wrong the cron does check and delete ghost ads all in one pass.

Jay

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #20 on: March 26, 2014, 11:37:56 pm »
@xilian,
The built in cron only runs if you have visitors to the user side of your site. So that maybe why it is not running for you.

I see. I'll see what happens on live site then. Re-installed everything there aswell

design

  • Hero Member
  • *****
  • Posts: 2619
  • Osclass 3.5 MAC/PC w/ Modern Browsers
Re: (Plugin) Ghostbuster 4.0
« Reply #21 on: March 26, 2014, 11:54:05 pm »
I un-installed GhostBuster 4.0, removed ./oc-content/plugins/ghost_fix/ and re-installed.
Will give feedback on outcome :)

These ghosts are pretty annoying... "The listing you are trying to delete couldn't be deleted"
but oh well..

is it because you changed your categories (deleted or moved)while there where ads still in them, including expired ads? if so, recreate that category then delete the ads

SmaRTeY

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2520
Re: (Plugin) Ghostbuster 4.0
« Reply #22 on: March 27, 2014, 02:58:28 am »
Cool, thanks.

@xilian,

The built in cron only runs if you have visitors to the user side of your site. So that maybe why it is not running for you.

@SmaRTeY,

There is some logging but currently the only way to see it is by looking in the db in the table t_log as that is the same log as osclass uses.

@Aficionado,

In my last post I stated it wrong the cron does check and delete ghost ads all in one pass.

Jay

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #23 on: March 27, 2014, 11:31:57 am »
is it because you changed your categories (deleted or moved)while there where ads still in them, including expired ads? if so, recreate that category then delete the ads

Nope! No change in categories. Users delete their own adds, then there are ghosts behind.
They are NOT automaticly removed, so cron cannot work.

Confirmed that it has to be done manually on my live site.
« Last Edit: March 27, 2014, 01:23:39 pm by xilian »

ben_dchost1

  • Jr. Member
  • **
  • Posts: 92
Re: (Plugin) Ghostbuster 4.0
« Reply #24 on: August 14, 2014, 12:14:43 pm »
I had 4-5 ghostadds and the plugin worked magnificently!  ;D

(Running bender theme with OS class 3.2.X)

Thanks OP!

xilian

  • Newbie
  • *
  • Posts: 35
Re: (Plugin) Ghostbuster 4.0
« Reply #25 on: August 15, 2014, 04:31:50 pm »
Old thread.
GB is working good, but I honestly think it should run more often that 60 mins.

But it works fine :)
« Last Edit: August 18, 2014, 09:31:33 am by trains58554 »

Helpto

  • Newbie
  • *
  • Posts: 45
Re: (Plugin) Ghostbuster 4.0
« Reply #26 on: December 08, 2014, 10:30:46 am »
Hello,

It is not working in latest Osclass 3.5.2. I'm using  Ghostbuster Version: 4.0.2.

It is showing "You currently have 0 ghost ads
You are ghost free! ". But still there are 2 ghost ads in my site after I upgrading to latest OSCLASS (3.5.2).

Check the below link.
http://www.helptobuynsell.in/real-estate/houses-for-sale-in-changanacherry

does anyone else have the same problem in Osclass 3.5.2.?

How to delete this ghost ads..?

Regards


SmaRTeY

  • Osclass Hero
  • Hero Member
  • *
  • Posts: 2520
Re: (Plugin) Ghostbuster 4.0
« Reply #27 on: January 17, 2015, 08:38:22 pm »
Could it be your cache?

I think I see two items that are premium without a photo or are these the 'ghost' items?


Regards,
Eric

Germar

  • Newbie
  • *
  • Posts: 24
Re: (Plugin) Ghostbuster 4.0
« Reply #28 on: August 15, 2019, 03:54:22 pm »
Hi,

I can't delete the adds that are corrupted. See picture
After install Ghostbuster these adds are still not gone, even after a day or 3
What is going wrong?

Please help?

regards Germar

Dimal

  • Full Member
  • ***
  • Posts: 121
Re: (Plugin) Ghostbuster 4.0
« Reply #29 on: August 15, 2019, 06:54:06 pm »
Apparently your CRON doesn't run. I think.

Is your debug.log empty ?