Advertisement:

Author Topic: [PLUGIN] Osclass Mail version 1.2 (works with Osclass 3.x)  (Read 33665 times)

teseo

  • Hero Member
  • *****
  • Posts: 6169
[PLUGIN] Osclass Mail version 1.2 (works with Osclass 3.x)
« on: July 16, 2013, 08:19:39 pm »
Hi everyone :)

This is a revision of the plugin made by rockitman187. Unfortunately, his last version (dated May 2012) won't work with latest versions of Osclass, and he seems to have gone missing from the forum. ???

So, I'm starting a fresh thread to continue his work with an updated version and hopefully continue improving it in the future. This is still almost as basic as the original plugin:

Version 1.2

- Use of keywords to customize mails.
- Mail to users, admin/s or both (for testing purposes)

ToDo:

- Throttling mechanism when sending a whole lot of mails at once.
- Premade templates.

I've included in the file latest TinyMCE to compose mails, so the file is bigger than the limit allowed for attachments in the forum. To avoid confusions when splitted in two files, please download from this address:

http://178.79.146.32/osclassmail/osclassmail_v1.2.zip

Best regards
« Last Edit: August 24, 2013, 08:47:55 pm by teseo »

jlightner86

  • Newbie
  • *
  • Posts: 11
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #1 on: July 16, 2013, 11:32:44 pm »
Thank you so much.  I am sure it will work fine.  I will be sure to let you know.

ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #2 on: July 17, 2013, 03:44:20 pm »
Thank you Teseo.

I will test it on bender black theme osclass 3.1.2 and let you know.

Are you open to feature suggestions?

If so, how far do you want to go with this?  I have a whole spec list I submitted somewhere else for new plugins, can get that for you.

Let me know

Cheers
Caz

teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #3 on: July 17, 2013, 04:29:03 pm »
Well, let's see that list and then I can tell you... :D

Regards

ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #4 on: July 17, 2013, 04:58:24 pm »
Okay :D

Here is my original post:
http://forums.osclass.org/plugins/request-your-plugin-here/msg61651/#msg61651

Don't fall off your chair.

Cheers
Caz

teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #5 on: July 17, 2013, 05:20:30 pm »
  :o :o :o

Look, I just wanted to share this little plugin effectively working for all the community, all that is material for some kind of premium plugin, and before even considering that, I'd like to see: first, if this is really working (still nobody saying "It's working for me" :D ) and then, if this is really needed by a fair amount of users, because 11 downloads so far don't seem very promissing to me. ???

Regards

ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #6 on: July 17, 2013, 06:09:58 pm »
Well, that is why I asked first if you wanted to take it further first; Sorry ... didn't mean to make demands or scare you.

It's early days yet, I am sure many people will love this fabulous plugin, just give it a little time.

Cheers
Caz

ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #7 on: July 17, 2013, 06:18:39 pm »
Okay, I have installed this super duper plugin, and it works fine.

I am using bender black and osclass 3.1.2 and I am sure it will work with osclass 3.2.

The only thing I am not sure if I did wrong or not is, I inserted a link to a page, and when clicked in the newsletter, it did not retain the full path.

I inserted these links:
Code: [Select]
Link 1:
http://www.ugogo.info/freeclassifiedads/news-p23

Link2:
http://www.ugogo.info/freeclassifiedads

But when emailed, the html shows the link was changed to:

Code: [Select]
Link 1:
http://../news-p23

Link 2:
...


So of course, when a person clicks it, the page cannot be found.

I used the Tiny MCE chain icon to insert those links, and copied and pasted them from the address bar, in their entirety starting from "http://".

Besides that, I wanted to tell you that all these things worked for me:

1.  Tiny Mce functions, all work fantastic and all the formatting was retained.
3.  The email went to about 400 people and it took about 3 minutes to arrive in my box.

Attached is a screenshot of the arrived newsletter :)

Thank you so much for this, to me this is an essential marketing and communication tool.


Cheers
Caz
« Last Edit: July 17, 2013, 06:20:51 pm by ugogo.info »

teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #8 on: July 17, 2013, 06:56:35 pm »
The only thing I am not sure if I did wrong or not is, I inserted a link to a page, and when clicked in the newsletter, it did not retain the full path.

I inserted these links:
Code: [Select]
Link 1:
http://www.ugogo.info/freeclassifiedads/news-p23

Link2:
http://www.ugogo.info/freeclassifiedads

But when emailed, the html shows the link was changed to:

Code: [Select]
Link 1:
http://../news-p23

Link 2:
...


So of course, when a person clicks it, the page cannot be found.

I used the Tiny MCE chain icon to insert those links, and copied and pasted them from the address bar, in their entirety starting from "http://".

Seems like some kind of TinyMCE bug. You copy or write down a link in the message, then you select it and the Link icon is enabled, you click on the Icon and in the pop-up the link should be already there, in the Link URL field. ??? But it's not so, so you'll have to paste it again there before hitting "Insert" or that error happens.

Regards

teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #9 on: July 17, 2013, 08:07:15 pm »
Come to think of it, there is no bug at all. A link is composed of two parts, the URL and the visible text. You could write "link", select it and click the Link icon and you wouldn't expect to find "link" in the Link URL field. :) What you select will be the visible text, you have to add the real URL in the pop-up. It's just that in this case both are the same, hence the confussion. ;)

One more thing to add to the ToDo list that I overlooked. You sent 400 emails at once and seems all went fine, but let's think you have to send 4000. Some kind of throttling mechanism would be needed, both to avoid your own server stress and to prevent big mailservers like GMail adding you to their black lists, their robots use to interpret this kind of massive communications as spam. :(

Regards


ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #10 on: July 17, 2013, 10:06:40 pm »
Hi Teseo

Quote
Seems like some kind of TinyMCE bug. You copy or write down a link in the message, then you select it and the Link icon is enabled, you click on the Icon and in the pop-up the link should be already there, in the Link URL field. ??? But it's not so, so you'll have to paste it again there before hitting "Insert" or that error happens.

It's ok, I write enough basic html code to write links in my sleep, and I also know how TinyMCE works - I definitely did all the right steps and the link did not work. 

Did you try test it yourself since my reply?  If you did, and it works for you, then I will test again, please let me know, thanks.



Quote
One more thing to add to the ToDo list that I overlooked. You sent 400 emails at once and seems all went fine, but let's think you have to send 4000

Great idea.   I did set up something like that in CPanel few years back, haven't been back to visit it though.  Seemed to work fine this time.

Cheers (A toast to you) <|_|
Caz


teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #11 on: July 17, 2013, 11:01:39 pm »
Hi Teseo

Quote
Seems like some kind of TinyMCE bug. You copy or write down a link in the message, then you select it and the Link icon is enabled, you click on the Icon and in the pop-up the link should be already there, in the Link URL field. ??? But it's not so, so you'll have to paste it again there before hitting "Insert" or that error happens.

It's ok, I write enough basic html code to write links in my sleep, and I also know how TinyMCE works - I definitely did all the right steps and the link did not work. 

Did you try test it yourself since my reply?  If you did, and it works for you, then I will test again, please let me know, thanks.

Oh, I see my not-so-good english must have betrayed me here... :D Those "you's" I meant them to be impersonal ("One selects..."), trying to describe what I was doing, of course I didn't know anything about your technical skills... ;)

Yes, I did test all this for myself... And just tested again rigth now, just in case I made some mistake... It's working fine here.

Say, just popped into my mind, with a small modification you can send mails only to the admins, ideal for testing this kind of things:

oc-content/plugins/osclassmail/osclassmail.php

Replace in line 21:

Code: [Select]
$users = User::newInstance()->listAll();
with

Code: [Select]
$users = Admin::newInstance()->listAll();
I think I will add this as an option in the Dashboard in the next revision. ;)

Regards

ugogo.info

  • Sr. Member
  • ****
  • Posts: 369
  • I just let my mind wander, and it didn’t come back
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #12 on: July 18, 2013, 04:54:56 pm »
Hey Teseo

No problem, I understand - I didn't know your first language isn't english.  In South Africa we have 11 official languages so I know about the translation hiccups.  LOL.  No of course, you could not know my technical skills, although I don't have many. 

I'd love to learn PHP and MySql but when I start doing the lessons at w3 schools I fall asleep.



Okay, what I will do is play with it over the next day or two and if I can't get it to work, I will make a video showing my actions so you can see.  If it can work, I will just list what I did wrong or what I did to fix it.


OOOH I love that idea of sending to admin only, then advertisers won't get bombarded with my test emails.  I can also test a draft to see if I make mistake before sending to the whole database.

Cheers!
Caz

creat15

  • Full Member
  • ***
  • Posts: 218
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #13 on: July 25, 2013, 06:59:25 pm »
hi teseo :)

i try your plugin osclass mail version 1.1 part 2

results are only sent to admin email only, user does not accept email sent from plugins osclas mail

what's the difference plugins osclass mail v1.1 part 1 and part 2?

Can you help me

Thank's

teseo

  • Hero Member
  • *****
  • Posts: 6169
Re: [PLUGIN] Osclass Mail version 1.1 (works with Osclass 3.x)
« Reply #14 on: July 25, 2013, 07:13:39 pm »
No, looks like I didn't explain well... :D There is only one plugin, but I've presented here split in two parts due to forum restriction for the size of attachments. Download both parts and extract their contents to same folder.

Regards