Advertisement:

Author Topic: [Free Plugin] Anti Spam & Protection System  (Read 65974 times)

gold1@bk.ru

  • Newbie
  • *
  • Posts: 1
Re: [Free Plugin] Anti Spam & Protection System
« Reply #990 on: November 13, 2018, 01:13:22 pm »
Hello. After installing the plug-in and entering the admin panel error appears
Warning: in_array() expects parameter 2 to be array, boolean given in C:\Webserver\OpenServer\domains\DOMAIN.COM\oc-content\plugins\spamprotection\classes\class.spamprotection.php on line 1349

Warning: Cannot modify header information - headers already sent by (output started at C:\Webserver\OpenServer\domains\DOMAIN.COM\oc-includes\osclass\utils.php:1744) in C:\Webserver\OpenServer\domains\BBS.KG\oc-includes\osclass\utils.php on line 1749

How to solve a problem?

davidyan

  • Newbie
  • *
  • Posts: 9
Re: [Free Plugin] Anti Spam & Protection System
« Reply #991 on: January 12, 2019, 09:47:12 pm »
Message for LIATH
Your plugin is really fantastic and even usin PHP 5.4 I managed to make it work.
I just modify into backend.php :
Quote
function sprot_install() {
    if (version_compare(phpversion(), '5.3', '<')) {
        trigger_error("I'm sorry, but you need to install at least PHP 5.5 to make use of this Plugin", E_USER_ERROR);
    }
    spam_prot::newInstance()->_install();
}
as I use PHP 5.4.45
Thanks again
Yan

Aficionado

  • issues
  • Hero Member
  • *
  • Posts: 6258
  • Hardliner
Re: [Free Plugin] Anti Spam & Protection System
« Reply #992 on: January 12, 2019, 10:03:53 pm »
Message for LIATH
Your plugin is really fantastic and even usin PHP 5.4 I managed to make it work.


as I use PHP 5.4.45
Thanks again
Yan

PHP versions less than 5.6 are NOT to be used. For many reasons, security is one of them. And speed an other.

If you use 5.4 then update asap. No reason to to stay at that very old version.
« Last Edit: January 13, 2019, 03:07:57 pm by Aficionado »

davidyan

  • Newbie
  • *
  • Posts: 9
Re: [Free Plugin] Anti Spam & Protection System
« Reply #993 on: January 13, 2019, 02:41:02 pm »
Hi Aficionado
I perfectly know that PHP 5.4 is deprecated and I am doing a lot of work to make software doing good with PHP 5.6 migration on my dedicated server
Thanks a lot for your message
Yan