Advertisement:

Author Topic: [Solved] gif Banner not working - Oslcasswizards  (Read 1244 times)

Darwazo

  • Full Member
  • ***
  • Posts: 112
[Solved] gif Banner not working - Oslcasswizards
« on: October 15, 2017, 12:59:14 am »
Hello everyone....

Gif Banner is not working - (Oslcasswizards) ...any thoughts? ideally it should work as theme saying gif,jpeg,png will work...file looks fine to me and is attached.

As always thanks you in advance for all help
« Last Edit: October 16, 2017, 02:41:35 am by Darwazo »

Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #1 on: October 15, 2017, 01:22:17 am »
is your banner saved as gif or converted to jpg?

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #2 on: October 15, 2017, 01:32:16 am »
Thank you liath for your time.
I converted 3 JPEG files to GIF File and it is Gif file.

Attached gif file is working but when I uploaded - its not working.

Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #3 on: October 15, 2017, 05:28:11 pm »
because of this i asked... is the uploaded image gif or jpg? where do you uploaded it... through theme settings? manually?


you could try to upload your gif manually and change the filename in your database

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #4 on: October 15, 2017, 05:55:43 pm »
Uploaded file is Gif and I did through Admin panel....Appearences/ osclasswizards/ Banner.....


I tried to figure out issue but somehow it seems file extension has changed from gif to png. (Attached screenshot)

I don't know where to upload file manually.......what to name it or activate it etc :(


Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #5 on: October 15, 2017, 06:48:14 pm »
upload it to ../oc-content/uploads/homeimage.gif and change filename in phpmyadmin from png to gif


table: _t_preferences
s_section: osclasswizards_theme
s_name: logo
« Last Edit: October 15, 2017, 06:56:40 pm by Liath »

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #6 on: October 15, 2017, 07:43:55 pm »
Thank you for detailed reply Liath .

I made those changes but still trigger is not happening on homepage. I tried even after cleaning cache.

Inspect of banner is still showing up http://localhost............/oc-content/uploads/homeimage.png  ??? ( File extension has not changed here in source code ) :( ....

Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #7 on: October 15, 2017, 07:57:30 pm »
sorry, wrong location...


s_name should be homeimage

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #8 on: October 15, 2017, 08:27:30 pm »
Thank You very much Liath for help out !!! Its working on localhost !! 
I did change logo to gif as well ...n i assume I can put logo as well as gif and that will be working ......

Thank you again !!

Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #9 on: October 15, 2017, 08:57:22 pm »
youre welcome :)

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #10 on: October 16, 2017, 01:45:46 am »
Hi Liath !! bugging you again......

I feel...there is one challenge attached to this method, which is I will not be able to upload "BANNER FROM ADMIN PANEL". I will always replace homeimage.gif with new homeimage.gif.

If I upload from admin panel , phpmyadmin  homeimage extension comes back to PNG extension (auto traigger because of upload).......any permanent solution? Admin panel suggest we can upload  all 3 extension (gif,png,jpeg).

Thanks

Liath

  • issues
  • Hero Member
  • *
  • Posts: 1346
  • </html> the end is always near
Re: gif Banner not working - Oslcasswizards
« Reply #11 on: October 16, 2017, 01:57:16 am »
no i'm sorry, it seems there are no permanent solutions without modyfying core files of osclass

Darwazo

  • Full Member
  • ***
  • Posts: 112
Re: gif Banner not working - Oslcasswizards
« Reply #12 on: October 16, 2017, 02:40:56 am »
Its okay Liath  !! ill try to manage within your help ...
Thanks alot & have a great day.