Loading


Advertisement:

Author Topic: updated twitter v3  (Read 4264 times)

design

  • Hero Member
  • *****
  • Posts: 2632
  • Osclass 3.5 MAC/PC w/ Modern Browsers
updated twitter v3
« on: April 22, 2014, 11:21:30 pm »
https://github.com/AlaskanDesigns/theme-twitter/tree/3.1.1
this is the same theme from the market that has been updated with the current version of twitter bootstrap classes, tested on osclass v 3.3.2

it does included all the fun stuff responsive and java script files from bootstrap, you can learn yourself at http://getbootstrap.com
there is a sample of the modal on item page (contact seller) that you can use where ever you'd like.

it is responsive, on the most basic level once you learn bootstrap, you can stack the classes as needed.

I will help as i can, but you should learn on your own, same for the script ;-)

innoserv

  • Newbie
  • *
  • Posts: 45
Re: updated twitter v3
« Reply #1 on: April 26, 2014, 03:49:49 pm »
hi design you do a great job thx

I would like to hide the display of prices on the item page when i choose job but dosen't work i try other theme it s work but twitter theme no did you have any idea thx again

searchweb

  • Jr. Member
  • **
  • Posts: 69
Re: updated twitter v3
« Reply #2 on: April 26, 2014, 05:01:58 pm »
same in here. It's also happen with repurpose theme. Seem the staff didn't update for both of that theme. The price can't disable, the core function when changing into bender or modern theme working fine. So the main problem with theme that not pass function to disable the prices when choosing disable price in admin panel. I have report this problem into github since 2 days ago but still noone reply. Really need help to fix the problem.
« Last Edit: April 26, 2014, 05:05:24 pm by searchweb »

design

  • Hero Member
  • *****
  • Posts: 2632
  • Osclass 3.5 MAC/PC w/ Modern Browsers
Re: updated twitter v3
« Reply #3 on: April 27, 2014, 07:43:55 pm »
I will look into these issues. When I started the theme, I checked for issues and fixes in the themes forum. These where not among them, and the required fields fields bug, where not among them.

Thank you for posting! I'll update this there'd and github as I fix them.

kuppusaj

  • Jr. Member
  • **
  • Posts: 53
  • Osclass is one of the wonderful Free Classified.
Re: updated twitter v3
« Reply #4 on: August 13, 2014, 09:53:26 am »
Still i am not able to post ad using  Twitter theme after downloaded twitter 3.1. Please suggest me on this

design

  • Hero Member
  • *****
  • Posts: 2632
  • Osclass 3.5 MAC/PC w/ Modern Browsers
Re: updated twitter v3
« Reply #5 on: August 13, 2014, 07:17:09 pm »
the function of the site is not theme related, as none of the URLS in the theme where modified, only classes. You have another issue.
I can try to help with more specifics, did you change themes & where able to post?


kuppusaj

  • Jr. Member
  • **
  • Posts: 53
  • Osclass is one of the wonderful Free Classified.
Re: updated twitter v3
« Reply #6 on: August 30, 2014, 06:59:07 pm »
I didnt chane any theme. but not able to post the ad using twitter theme, but other themes working fine apart from Twitter theme

kuppusaj

  • Jr. Member
  • **
  • Posts: 53
  • Osclass is one of the wonderful Free Classified.
Re: updated twitter v3
« Reply #7 on: August 30, 2014, 07:02:47 pm »
Can you send me the updated twitter theme?

Adyyda

  • Sr. Member
  • ****
  • Posts: 455
Re: updated twitter v3
« Reply #8 on: April 28, 2016, 11:33:07 am »
Since the theme is not finalised (unfortunately), i have found 2 issues which took a long time to solve. Both are visible only when you try to install certain plugins that require certain code available by default in bender or modern to work properly

1. Error messages from Backoffice manager do not show

For this you may use as a base the code

Code: [Select]
<?php osc_enqueue_script('jquery-validate'); ?>
<!DOCTYPE html>
<html dir="ltr" lang="<?php echo str_replace('_''-'osc_current_user_locale()) ; ?>">
    <head>
        <?php osc_current_web_theme_path('head.php') ; ?>
        <meta name="robots" content="noindex, nofollow" />
        <meta name="googlebot" content="noindex, nofollow" />
    </head>
    <body>
        <?php UserForm::js_validation(); ?>
        <?php osc_current_web_theme_path('header.php') ; ?>
        <div class="content">
            <div class="well">
                <form class="form-horizontal" name="register" id="register" action="<?php echo osc_base_url(true); ?>" method="post" >
                    <input type="hidden" name="page" value="register" />
                    <input type="hidden" name="action" value="register_post" />
                        <h1><?php _e('Register an account for free''twitter') ; ?></h1>
                        <div class="form-group">
                            <label class="col-md-3 control-label" for="s_name"><?php _e('Name''twitter') ; ?> *</label>
                            <div class="col-md-8">
                                <?php UserForm::name_text(); ?>
                            </div>
                        </div>
                        <div class="form-group">
                            <label class="col-md-3 control-label" for="s_password"><?php _e('Password''twitter') ; ?> *</label>
                            <div class="col-md-8">
                                <?php UserForm::password_text(); ?>
                            </div>
                        </div>
                        <div class="form-group">
                            <label class="col-md-3 control-label" for="s_password2"><?php _e('Re-type password''twitter') ; ?> *</label>
                            <div class="col-md-8">
                                <?php UserForm::check_password_text(); ?>
                            </div>
                        </div>
                        <div class="form-group">
                            <label class="col-md-3 control-label" for="s_email"><?php _e('E-mail''twitter') ; ?> *</label>
                            <div class="col-md-8">
                                <?php UserForm::email_text(); ?>
                            </div>
                        </div>
                        <div class="form-group">
                            <?php osc_run_hook('user_register_form') ; ?>
                        </div>
                        <div class="form-group">
                            <div class="col-sm-4 col-sm-offset-4">
                                <?php osc_show_recaptcha('register'); ?>
                                <button class="btn btn-success" type="submit"><?php _e('Register''twitter') ; ?></button>
                            </div>
                        </div>
                        <div class="form-group">
                            <div class="col-sm-7">
                                <a href="<?php echo osc_recover_user_password_url() ; ?>"><?php _e("Forgot password?"'twitter') ; ?></a>
                            </div>
                        </div>
                </form>
            </div>
        </div>
        <nav class="navbar navbar-static-bottom">
            <div class="container">
             <?php osc_current_web_theme_path('footer.php') ; ?>
            </div>
          </nav>
    </body>
</html>


Mentions:
- the code is row to solve just the issue, you must add css style to adjust it properly
- register.js code is not required anymore because we will use the <?php UserForm: instead and you can compare my code with the one from original theme to see all the changes
- by default, we would have all the errors in a block but i changed that since i do not like it so now, each field will show beneath it's error
- the changes made can be applied in other files that have same issues with messages
- do not change class h1 from <h1><?php _e('Register an account for free', 'twitter') ; ?></h1> because the messages will stop showing - i assume that this is how userform use them

2.  In user account, when i accessed pages created by certain plugins like a message plugin i found that the website was changed from twitter into bender (that has several threads on the forum) so in my case i had to create a new file called user-custom.php with the code
Code: [Select]
<!DOCTYPE html>
<html dir="ltr" lang="<?php echo str_replace('_''-'osc_current_user_locale()) ; ?>">
    <head>
        <?php osc_current_web_theme_path('head.php') ; ?>
        <meta name="robots" content="noindex, nofollow" />
        <meta name="googlebot" content="noindex, nofollow" />
    </head>
    <body>
        <?php osc_current_web_theme_path('header.php') ; ?>
        <?php twitter_show_flash_message() ; ?>
        <div class="content">
            <div class="row">
                <div class="col-md-3">
                    <?php twitter_user_menu() ; ?>
                </div>
                <div class="col-md-9">
                    <?php osc_render_file(); ?>
                </div>
        </div>
      </div>
      <nav class="navbar navbar-static-bottom">
        <div class="container">
         <?php osc_current_web_theme_path('footer.php') ; ?>
        </div>
      </nav>
    </body>
</html>

Once i uploaded that file in the theme folder, all pages were fine and required just minor css changes in the plugin to adjust it to the look of twitter.

Like i've said, these are just to solve functionality issues and do require css adjustment from you. Anyway, i hope these will help you.
« Last Edit: April 28, 2016, 11:34:50 am by Adyyda »